Signup Issues

Incident Report for PredictHQ

Resolved

This incident has been resolved.
Posted Aug 06, 2026 - 15:58 NZST

Investigating

We've identified and fixed a backend issue that was preventing some sign-ups from completing successfully.
Posted Aug 06, 2026 - 15:57 NZST